summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:22:08 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:41:43 +0200
commit0bf8f9873791c9fbb3c0cd0c8831e80b580d6190 (patch)
tree5f9569fb51a00a4b2bb048ab32f89530fb1f2c2c /gnu/packages
parent5367f764e175b54671478171c0d8acd7529f6c01 (diff)
downloadguix-0bf8f9873791c9fbb3c0cd0c8831e80b580d6190.tar.gz
gnu: Add texlive-hep.
* gnu/packages/tex.scm (texlive-hep): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 368e1cd71d..574f300464 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3922,6 +3922,25 @@ theoretical texts, program notes, symbol legends, etc.  Documents must be
 compiled using XeLaTeX.")
     (license license:cc-by4.0)))
 
+(define-public texlive-hep
+  (package
+    (name "texlive-hep")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/hep/" "tex/latex/hep/")
+             (base32
+              "1p7phgv3d4xch9c9qwkpgrpc34nzijxfxiqkpnc9b9a3xfwh71sg")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/hep")
+    (synopsis "Convenience wrapper for High Energy Physics packages")
+    (description
+     "This package loads the author's @code{hepunits} and @code{hepnicenames}
+packages, and a selection of others that are useful in High Energy Physics
+papers, etc.")
+    (license license:lppl)))
+
 (define-public texlive-bibtex8
   (package
     (name "texlive-bibtex8")