summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-10-28 13:59:32 -0400
committerLeo Famulari <leo@famulari.name>2016-10-28 13:59:32 -0400
commit0df955401f645214848d51bd1d44878beff30d65 (patch)
tree40b78c5abaac4380b69a760db6fac2f038c980c7 /gnu/packages
parenta6447e7fb6a12f4a15b6bcffe09d97f78564f325 (diff)
parent044ac8d2947ffe3775ab8bb70b264bfb2a1310ce (diff)
downloadguix-0df955401f645214848d51bd1d44878beff30d65.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioinformatics.scm9
-rw-r--r--gnu/packages/emacs.scm26
2 files changed, 33 insertions, 2 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 4e9397e14e..4750cb97bf 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1426,15 +1426,20 @@ also includes an interface for tabix.")
 (define-public python-twobitreader
   (package
     (name "python-twobitreader")
-    (version "3.1.2")
+    (version "3.1.4")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "twobitreader" version))
               (sha256
                (base32
-                "0y408fp6psqzwxpcpqn0wp7fr41dwz8d54wpj6j261fj5q8vs169"))))
+                "1q8wnj2kga9nz1lwc4w7qv52smfm536hp6mc8w6s53lhyj0mpi22"))))
     (properties `((python2-variant . ,(delay python2-twobitreader))))
     (build-system python-build-system)
+    (arguments
+     '(;; Tests are not distributed in the PyPi release.
+       ;; TODO Try building from the Git repo or asking the upstream maintainer
+       ;; to distribute the tests on PyPi.
+       #:tests? #f))
     (native-inputs
      `(("python-sphinx" ,python-sphinx)))
     (home-page "https://github.com/benjschiller/twobitreader")
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 5131628178..7c147845fd 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -2086,6 +2086,32 @@ number.")
 @code{org-mode} to be rendered as UTF-8 characters.")
     (license license:gpl3+)))
 
+(define-public emacs-org-trello
+  (package
+    (name "emacs-org-trello")
+    (version "0.7.9")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/org-trello/org-trello/archive/"
+                    version ".tar.gz"))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "074dka8g673bj1ck5vavbjaij5jyniygdlw51mdds005wd2br9wf"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-deferred" ,emacs-deferred)
+       ("emacs-request" ,emacs-request)
+       ("emacs-dash" ,emacs-dash)
+       ("emacs-s" ,emacs-s)))
+    (home-page "https://org-trello.github.io")
+    (synopsis "Emacs minor mode for interacting with Trello")
+    (description "This package provides an Emacs minor mode to extend
+@code{org-mode} with Trello abilities.  Trello is an online project
+organizer.")
+    (license license:gpl3+)))
+
 (define-public emacs-zenburn-theme
   (package
     (name "emacs-zenburn-theme")