summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorzamfofex <zamfofex@twdb.moe>2023-06-14 09:48:45 -0300
committerLudovic Courtès <ludo@gnu.org>2023-07-07 15:30:22 +0200
commit0f9953c959b5614637e0a7a5d2e2158c3f18314c (patch)
tree4f68b3eb9f35ab628e3257a8edfafe9205b0f502 /gnu/packages
parentf3a180296abc97f0a05a5526ed1838332b991918 (diff)
downloadguix-0f9953c959b5614637e0a7a5d2e2158c3f18314c.tar.gz
gnu: Add ghc-generic-lens-core.
* gnu/packages/haskell-xyz.scm (ghc-generic-lens-core): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/haskell-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 9e8bed6016..f4318644aa 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -6360,6 +6360,32 @@ polymorphism.  @code{Lens.Family.Clone} allows for first-class support of
 lenses and traversals for those who require Haskell 98.")
     (license license:bsd-3)))
 
+(define-public ghc-generic-lens-core
+  (package
+    (name "ghc-generic-lens-core")
+    (version "2.2.1.0")
+    (source (origin
+              (method url-fetch)
+              (uri (hackage-uri "generic-lens-core" version))
+              (sha256
+               (base32
+                "08i4c9yb6z84iknrnl9f3f343121j7ilp0a679v81nsjm9xz3rlf"))))
+    (build-system haskell-build-system)
+    (properties '((upstream-name . "generic-lens-core")))
+    (inputs (list ghc-indexed-profunctors))
+    (arguments
+     `(#:cabal-revision ("1"
+                         "1dbjhd6k7ypqa9f4h9v2xndgb4mjhfli3n1vjm8r8ga0kfndbqfn")))
+    (home-page "https://github.com/kcsongor/generic-lens")
+    (synopsis "Generically derive traversals, lenses and prisms.")
+    (description
+     "This library uses GHC.Generics to derive efficient optics (traversals,
+lenses and prisms) for algebraic data types in a type-directed way, with a
+focus on good type inference and error messages when possible.  This package
+is the shared internal logic of the @code{generic-lens} and
+@code{generic-optics} libraries.")
+    (license license:bsd-3)))
+
 (define-public ghc-libffi
   (package
     (name "ghc-libffi")