summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2021-03-27 07:29:25 -0400
committerMark H Weaver <mhw@netris.org>2021-03-27 19:48:46 -0400
commit11d73170c5eee450b9b2f2dd444457850389e6a2 (patch)
treed3189c555792d47aa51219b5f97598a3d909e229 /gnu/packages
parent69437a59e67634f85477a5eadab092598aa57ee1 (diff)
downloadguix-11d73170c5eee450b9b2f2dd444457850389e6a2.tar.gz
gnu: gtk-doc: Add 'gtk-doc/stable' variant.
* gnu/packages/gtk.scm (gtk-doc/stable): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gtk.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index cf9116214c..52710b4687 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -48,6 +48,7 @@
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix git-download)
+  #:use-module ((guix build utils) #:select (alist-replace))
   #:use-module (guix build-system glib-or-gtk)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system meson)
@@ -1829,6 +1830,17 @@ typically used to document the public API of GTK+ and GNOME libraries, but it
 can also be used to document application code.")
     (license license:gpl2+)))
 
+;; This is a variant of the 'gtk-doc' package that is not updated often.  It
+;; is intended to be used as a native-input at build-time only.  This allows
+;; the main 'gtk-doc', 'dblatex' and 'imagemagick' packages to be freely
+;; updated on the 'master' branch without triggering an excessive number of
+;; rebuilds.
+(define-public gtk-doc/stable
+  (hidden-package
+   (package/inherit gtk-doc
+     (inputs (alist-replace "dblatex" `(,dblatex/stable)
+                            (package-inputs gtk-doc))))))
+
 (define-public gtk-engines
   (package
     (name "gtk-engines")