summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-10-22 20:36:28 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-10-24 21:34:21 +0200
commit11d99192c76e36d6aeb9998749d3d50d1937561e (patch)
tree0c27bb67c142ef0c2e31a4b92aba658cc1dde108 /gnu/packages
parentd4eb8a21a6bd5df9126290208d275c94d65c95e3 (diff)
downloadguix-11d99192c76e36d6aeb9998749d3d50d1937561e.tar.gz
gnu: Add python-reparser.
* gnu/packages/python.scm (python-reparser, python2-reparser):
New public variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index d9f3ebfc55..fbb280224a 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14551,3 +14551,29 @@ are not supported.")
 
 (define-public python2-readlike
   (package-with-python2 python-readlike))
+
+(define-public python-reparser
+  (package
+    (name "python-reparser")
+    (version "1.4.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "ReParser" version))
+       (sha256
+        (base32 "0nniqb69xr0fv7ydlmrr877wyyjb61nlayka7xr08vlxl9caz776"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/xmikos/reparser")
+    (synopsis "Simple lexer/parser for inline markup based on regular expressions")
+    (description
+     "This Python library provides a simple lexer/parser for inline markup based
+on regular expressions.")
+    (license license:expat)))
+
+(define-public python2-reparser
+  (let ((reparser (package-with-python2
+                   (strip-python2-variant python-reparser))))
+    (package (inherit reparser)
+             (propagated-inputs
+              `(("python2-enum34" ,python2-enum34)
+                ,@(package-propagated-inputs reparser))))))