summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-08-09 10:52:25 +0200
committerMarius Bakke <marius@gnu.org>2022-08-11 22:39:13 +0200
commit121f6e0b0c45dba24301fbd405d07123e82c2de6 (patch)
tree1ea8fb275600b0838974d65738c3aee96470c867 /gnu/packages
parent126648f5787a3045e5deb9204c226383ff428e73 (diff)
downloadguix-121f6e0b0c45dba24301fbd405d07123e82c2de6.tar.gz
gnu: texlive-xcolor: Fix build failure.
This is a reland of 5e796bfc22076a1126beaa853d9cac16f5c9a23d which was
partially reverted in 8c3e9da13a3c92a7db308db8c0d81cb474ad7799.

* gnu/packages/tex.scm (texlive-xcolor)[arguments]: Make sure package provides
all the expected files.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 16 insertions, 9 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3ad16a1b46..8e80f23f18 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3390,15 +3390,22 @@ used by @code{hyperref} and @code{bookmark}.")
          ((#:phases phases)
           #~(modify-phases #$phases
               (add-after 'unpack 'chdir
-                (lambda _ (chdir "source/latex/xcolor") #t))
-              (add-after 'install 'move-files
-                (lambda* (#:key outputs #:allow-other-keys)
-                  (let ((share (string-append (assoc-ref outputs "out")
-                                              "/share/texmf-dist")))
-                    (mkdir-p (string-append share "/dvips/xcolor"))
-                    (rename-file (string-append share "/tex/latex/xcolor/xcolor.pro")
-                                 (string-append share "/dvips/xcolor/xcolor.pro"))
-                    #t)))))))
+                (lambda _ (chdir "source/latex/xcolor")))
+              (replace 'copy-files
+                (lambda* (#:key inputs outputs #:allow-other-keys)
+                  (let ((origin (assoc-ref inputs "source"))
+                        (source (string-append #$output
+                                               "/share/texmf-dist/source"))
+                        (doc (string-append #$output:doc
+                                            "/share/texmf-dist/doc")))
+                    (copy-recursively (string-append origin "/source") source)
+                    (copy-recursively (string-append origin "/doc") doc)
+                    (let ((share (string-append #$output
+                                                "/share/texmf-dist")))
+                      (mkdir-p (string-append share "/dvips/xcolor"))
+                      (rename-file
+                       (string-append share "/tex/latex/xcolor/xcolor.pro")
+                       (string-append share "/dvips/xcolor/xcolor.pro"))))))))))
       ;; TODO: Propagate texlive-hyperref and many others in the next rebuild
       ;; cycle.  Grep for '\usepackage' to see what packages it requires.
       ;; (propagated-inputs (list texlive-hyperref ...))