summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2023-12-22 21:19:10 +0800
committerHilton Chain <hako@ultrarare.space>2023-12-22 21:57:51 +0800
commit1784ece7cb61dc72a43cf8e0ad17fdbb266320e6 (patch)
tree22eb249c089c025c720ca943d4250a81980f505d /gnu/packages
parent4d494010316b9760a5779c752f2497ae725ac0e5 (diff)
downloadguix-1784ece7cb61dc72a43cf8e0ad17fdbb266320e6.tar.gz
gnu: Add glad, version 2.0.4.
* gnu/packages/gl.scm (glad): New variable.

Change-Id: I516d44dfc9272702c3ac31773df0b6c2d68ed99c
Modified-by: Hilton Chain <hako@ultrarare.space>
Signed-off-by: Hilton Chain <hako@ultrarare.space>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gl.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 06854f36f7..192b5e84e0 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -18,6 +18,7 @@
 ;;; Copyright © 2021, 2022, 2023 John Kehayias <john.kehayias@protonmail.com>
 ;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
 ;;; Copyright © 2023 Kaelyn Takata <kaelyn.alexi@protonmail.com>
+;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -221,6 +222,32 @@ Polygon meshes, and Extruded polygon meshes.")
 generate a GL/GLES/EGL/GLX/WGL loader tailored for specific requirements.")
     (license license:expat)))
 
+(define-public glad
+  (package
+    (inherit glad-0.1)
+    (name "glad")
+    (version "2.0.4")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/Dav1dde/glad")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1pam6imhcmcyqrqi6wzzxprb23y8x6zdbvsjavnz26k72i9dbbja"))))
+    (build-system python-build-system)
+    (arguments
+     (substitute-keyword-arguments (package-arguments glad-0.1)
+       ((#:phases phases '%standard-phases)
+        #~(modify-phases #$phases
+            (replace 'install-cmakelists.txt
+              (lambda _
+                (let ((share (string-append #$output "/share/"
+                                            #$(package-name this-package))))
+                  (install-file "cmake/CMakeLists.txt" share))))))))
+    (propagated-inputs (list python-jinja2))))
+
 (define-public s2tc
   (package
     (name "s2tc")