summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 16:21:15 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:10:54 +0200
commit19e844a2a2959e25c9c856434d916b9240a8065e (patch)
tree1322277f9926479104f5060429c3133aaf2060f8 /gnu/packages
parent459251d0a52a0f06a307ec1c0f109942dc2ce17d (diff)
downloadguix-19e844a2a2959e25c9c856434d916b9240a8065e.tar.gz
gnu: Add texlive-njuvisual.
* gnu/packages/tex.scm (texlive-njuvisual): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 9dd3ba411c..2b158aa630 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -23262,6 +23262,27 @@ and doctoral theses as well as postdoctoral reports.  Compilation of this
 class requires either XeLaTeX or LuaLaTeX.")
     (license license:lppl1.3c)))
 
+(define-public texlive-njuvisual
+  (package
+    (name "texlive-njuvisual")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/njuvisual/"
+                   "source/latex/njuvisual/"
+                   "tex/latex/njuvisual/")
+             (base32
+              "1v5iv44wi0hh77j56jjccgyrh9kyyfvzbl305vqryphq0r73bk36")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/njuvisual")
+    (synopsis "Display logos related to Nanjing University")
+    (description
+     "The njuvisual package collects standard colors and logos related to
+Nanjing University, saves the vector logos as TikZ pictures and provides
+a user-friendly interface to display them in documents and beamers.")
+    (license license:lppl1.3c)))
+
 (define-public texlive-nucleardata
   (package
     (name "texlive-nucleardata")