summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 11:59:05 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 11:59:05 +0200
commit1c9d5a93c68d3e92e8aa23689489153ef13f7523 (patch)
tree4be152042969b8fd3729ca49092fb5a74c7b2542 /gnu/packages
parent6fe19aea32c9b5fd05ca1908bc3e5e5717b9aacd (diff)
downloadguix-1c9d5a93c68d3e92e8aa23689489153ef13f7523.tar.gz
gnu: Add texlive-ascmac.
* gnu/packages/tex.scm (texlive-ascmac): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 765a64b3bf..b33e3f8dee 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2392,6 +2392,32 @@ package.")
 converted between Plain TeX and LaTeX by a simple editing action.")
     (license license:lppl1.3+)))
 
+(define-public texlive-ascmac
+  (package
+    (name "texlive-ascmac")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/ascmac/"
+                   "fonts/map/dvips/ascmac/"
+                   "fonts/source/public/ascmac/"
+                   "fonts/tfm/public/ascmac/"
+                   "fonts/type1/public/ascmac/"
+                   "source/latex/ascmac/"
+                   "tex/latex/ascmac/")
+             (base32
+              "1d388nqyjipqsgd0pd4zrskaf3wddacg6rrmy3q1n8pvmna4gmz1")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (native-inputs (list texlive-metafont))
+    (home-page "https://ctan.org/pkg/ascmac")
+    (synopsis "Boxes and picture macros with Japanese vertical writing support")
+    (description
+     "The bundle provides boxes and picture macros with Japanese vertical
+writing support.  It uses only native picture macros and fonts for drawing
+boxes and is thus driver independent.")
+    (license license:bsd-3)))
+
 (define-public texlive-asymptote-by-example-zh-cn
   (package
     (name "texlive-asymptote-by-example-zh-cn")