summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAndrew Tropin <andrew@trop.in>2022-11-28 13:36:36 +0400
committerAndrew Tropin <andrew@trop.in>2022-11-28 13:36:36 +0400
commit1cc89f0be39e5e4e5259a90d0366273ecba5409b (patch)
treede9f96fe051f662f5b5e37808d8c00e21be9a691 /gnu/packages
parentfd0bd21e6699b5fcfc7fb02edb2004f1e43352d9 (diff)
downloadguix-1cc89f0be39e5e4e5259a90d0366273ecba5409b.tar.gz
Revert "gnu: rust-clap-derive-3: Update to 3.1.18."
This reverts commit 7760e3fb094928c809ab894c476cbf974e556891.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 401c300c56..2da61b385e 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -10458,20 +10458,23 @@ traits.")
 (define-public rust-clap-derive-3
   (package
     (name "rust-clap-derive")
-    (version "3.1.18")
+    (version "3.0.0-beta.2")
     (source
      (origin
        (method url-fetch)
        (uri (crate-uri "clap_derive" version))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
        (sha256
-        (base32 "0g53w6qkqcc122bqh51jzfg51147il643idvq1czxkr2x5306ci5"))))
+        (base32
+         "18cn82jhcha7m0nkpi1a03jx8k7aaq5kxfcxnsqpaa8ih5dp23rp"))))
     (build-system cargo-build-system)
     (arguments
      `(#:skip-build? #t
        #:cargo-inputs
-       (("rust-heck" ,rust-heck-0.4)
-        ("rust-proc-macro-error" ,rust-proc-macro-error-1)
+       (("rust-heck" ,rust-heck-0.3)
+        ("rust-proc-macro-error"
+         ,rust-proc-macro-error-1)
         ("rust-proc-macro2" ,rust-proc-macro2-1)
         ("rust-quote" ,rust-quote-1)
         ("rust-syn" ,rust-syn-1))))