summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2023-07-23 18:38:06 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2024-02-24 16:42:41 +0100
commit1cce580311a65a4e85b49b315ee7f8df0244d444 (patch)
treea1294b5929628af24ce11d6f85991352e4edb601 /gnu/packages
parent603a8330436c5c487ccf81c7e33ee5ab79dadc99 (diff)
downloadguix-1cce580311a65a4e85b49b315ee7f8df0244d444.tar.gz
gnu: Add ruby-net-sftp.
* gnu/packages/ruby.scm (ruby-net-sftp): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ruby.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 9715e2c2a2..aa4ea91e50 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5584,6 +5584,27 @@ client protocol.")
     (home-page "https://github.com/net-ssh/net-scp")
     (license license:expat)))
 
+(define-public ruby-net-sftp
+  (package
+    (name "ruby-net-sftp")
+    (version "4.0.0")
+    (source (origin
+              (method url-fetch)
+              (uri (rubygems-uri "net-sftp" version))
+              (sha256
+               (base32
+                "0r33aa2d61hv1psm0l0mm6ik3ycsnq8symv7h84kpyf2b7493fv5"))))
+    (build-system ruby-build-system)
+    (propagated-inputs (list ruby-net-ssh))
+    (synopsis "Pure Ruby implementation of the SFTP client protocol")
+    (description
+     "@code{Net::SFTP} is a pure Ruby implementation of the SFTP
+protocol (specifically, versions 1 through 6 of the SFTP protocol).  Note that
+this is the “Secure File Transfer Protocol”, typically run over an SSH
+connection, and has nothing to do with the FTP protocol.")
+    (home-page "https://github.com/net-ssh/net-sftp")
+    (license license:expat)))
+
 (define-public ruby-minima
   (package
     (name "ruby-minima")