summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 15:46:51 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:10:35 +0200
commit1d2411be0cb8e7faa5912f7b5d4f047db9a23390 (patch)
tree2c2c6d6824bbaf23fcb5fa671d36bb2f9d0a24dc /gnu/packages
parent0106ede60794b0c76a4d368dd81b30620974a902 (diff)
downloadguix-1d2411be0cb8e7faa5912f7b5d4f047db9a23390.tar.gz
gnu: Add texlive-hithesis.
* gnu/packages/tex.scm (texlive-hithesis): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 84fd7197be..20d45f90fc 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -16311,6 +16311,36 @@ University of Technology Graduate Dissertation Writing Specifications} and
 Work Implementation Rules}.")
     (license license:lppl1.3c)))
 
+(define-public texlive-hithesis
+  (package
+    (name "texlive-hithesis")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "bibtex/bst/hithesis/"
+                   "doc/xelatex/hithesis/"
+                   "makeindex/hithesis/"
+                   "source/xelatex/hithesis/"
+                   "tex/xelatex/hithesis/")
+             (base32
+              "0w701f0ivf7k8jb2jiy5lhns4qiflyrslyiplm6aca67g2rcqgwn")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               ;; "hithesis.ins" writes files to "./figures" Create these
+               ;; directories first to prevent an error.
+               (add-before 'build 'prepare-build
+                 (lambda _
+                   (mkdir-p "build/figures"))))))
+    (home-page "https://ctan.org/pkg/hithesis")
+    (synopsis "Harbin Institute of Technology thesis template")
+    (description
+     "@code{hithesis} is a LaTeX thesis template package for Harbin Institute
+of Technology supporting bachelor, master, doctor dissertations.")
+    (license license:lppl1.3a)))
+
 (define-public texlive-hindmadurai
   (package
     (name "texlive-hindmadurai")