summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorBruno Victal <mirai@makinata.eu>2023-10-09 21:06:13 +0100
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:42:10 +0200
commit1e41770dfe0f1e63298183392ef64bc30ab16049 (patch)
treeb167d002923c8ad2a2fb3e90f634dd9a793e24ce /gnu/packages
parentf678c5f932a0dec3a22abc6a3feb608be59225e6 (diff)
downloadguix-1e41770dfe0f1e63298183392ef64bc30ab16049.tar.gz
gnu: gtk-doc: Add libxslt native-search-paths to its own.
Grepping through the built package, gtk-doc invokes 'xsltproc' so we add
%libxslt-search-paths to native-search-paths in order for 'xsltproc' to find
the XML/SGML catalog files.

* gnu/packages/gtk.scm (gtk-doc)[native-search-paths]: Add %libxslt-search-paths.

Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gtk.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 01cb5cf4fc..5febaedf7c 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -61,6 +61,7 @@
   #:use-module (guix download)
   #:use-module (guix bzr-download)
   #:use-module (guix git-download)
+  #:use-module (guix search-paths)
   #:use-module ((guix build utils) #:select (alist-replace))
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system glib-or-gtk)
@@ -2316,6 +2317,8 @@ information.")
            python-pygments
            source-highlight
            yelp-tools))
+    ;; xsltproc's search paths, to avoid propagating libxslt.
+    (native-search-paths %libxslt-search-paths)
     (home-page "https://wiki.gnome.org/DocumentationProject/GtkDoc")
     (synopsis "GTK+ DocBook Documentation Generator")
     (description "GtkDoc is a tool used to extract API documentation from C-code