summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2015-08-16 16:38:06 +0200
committerCyril Roelandt <tipecaml@gmail.com>2015-09-01 23:14:25 +0200
commit1edd421ba51e89cbcfa536c65437da24d52ce237 (patch)
tree7395ca983c427fc6a1353cd718ea1d12db0dc1a9 /gnu/packages
parent35f1ebeb2acb06dd920baffc7b3a184b7c45cd15 (diff)
downloadguix-1edd421ba51e89cbcfa536c65437da24d52ce237.tar.gz
gnu: Add python-os-client-config
* gnu/packages/openstack.scm (python-os-client-config,
  python2-os-client-config): New variables.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/openstack.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index 48bc716bc5..f3b47ae08c 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -55,6 +55,45 @@ with mox as possible, but small enhancements have been made. The library was
 tested on Python version 3.2, 2.7 and 2.6.")
     (license asl2.0)))
 
+(define-public python-os-client-config
+  (package
+    (name "python-os-client-config")
+    (version "1.4.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append
+               "https://pypi.python.org/packages/source/o/os-client-config/os-client-config-"
+               version
+               ".tar.gz"))
+        (sha256
+          (base32
+            "14png6ml3zbbilh8bihav24f8vig9lyijwynnjcvazdxxrzvwq9j"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:tests? #f)) ;; Circular dependency with python-oslotest
+    (inputs
+      `(("python-appdirs" ,python-appdirs)
+        ("python-fixtures" ,python-fixtures)
+        ("python-mimeparse" ,python-mimeparse)
+        ("python-pbr" ,python-pbr)
+        ("python-pyyaml" ,python-pyyaml)
+        ("python-testrepository" ,python-testrepository)
+        ("python-setuptools" ,python-setuptools)
+        ("python-testscenarios" ,python-testscenarios)
+        ("python-testtools" ,python-testtools)))
+    (home-page "http://www.openstack.org/")
+    (synopsis
+      "OpenStack Client Configuration Library")
+    (description
+      "The OpenStack Client Configuration Library is a library for collecting
+  client configuration for using an OpenStack cloud in a consistent and
+  comprehensive manner.")
+    (license asl2.0)))
+
+(define-public python2-os-client-config
+  (package-with-python2 python-os-client-config))
+
 (define-public python2-mox3
   (package-with-python2 python-mox3))