summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-10-22 14:04:06 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-10-30 12:07:53 +0100
commit1f6f4c40c1fda1583f96881d9fda11c5c5a0ad92 (patch)
tree40567fa1e21fe9329316f896d0aa7be8a08671e3 /gnu/packages
parent7941d1ed5ddb05292b108dce1a389d56066f9b28 (diff)
downloadguix-1f6f4c40c1fda1583f96881d9fda11c5c5a0ad92.tar.gz
gnu: Add r-tgconfig.
* gnu/packages/statistics.scm (r-tgconfig): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/statistics.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 1c97fdb156..3367c7aa46 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -5502,3 +5502,28 @@ manually \"recoding\").")
        "The goal of tgstat is to provide fast and efficient statistical
 tools.")
       (license license:gpl2))))
+
+(define-public r-tgconfig
+  (let ((changeset "1e02c7614713bd0866c46f0c679a058f8c6d627e")
+        (revision "1"))
+    (package
+      (name "r-tgconfig")
+      (version (string-append "0.0.0.9000-" revision "." (string-take changeset 7)))
+      (source
+       (origin
+         (method hg-fetch)
+         (uri (hg-reference
+               (url "https://bitbucket.org/tanaylab/tgconfig")
+               (changeset changeset)))
+         (sha256
+          (base32
+           "0xy6c7s7mn1yx191154bwbv1bl424bnvc80syqpl1vdl28ba46rj"))))
+      (build-system r-build-system)
+      (propagated-inputs
+       `(("r-yaml" ,r-yaml)))
+      (home-page "https://bitbucket.org/tanaylab/tgconfig/")
+      (synopsis "Infrastructure for managing package parameters")
+      (description
+       "The goal of tgconfig is to provide infrastructure for managing package
+parameters.")
+      (license license:gpl3))))