summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTor-björn Claesson <tclaesson@gmail.com>2022-12-28 02:23:53 +0200
committerLudovic Courtès <ludo@gnu.org>2023-01-05 23:05:41 +0100
commit1fa87755057347f8893ec137cc5a7550a23f241f (patch)
tree787909f538d06f4d0e5ee0cbdc06f72592809528 /gnu/packages
parentc7158acfba1f992e3e6451761ab1174067c3fd85 (diff)
downloadguix-1fa87755057347f8893ec137cc5a7550a23f241f.tar.gz
gnu: Add charls.
* gnu/packages/image-processing.scm (charls): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/image-processing.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index 85acc3f5b5..70c820e76b 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -1748,3 +1748,31 @@ segmentation.")
       "Image and video labeling tool supporting different shapes like
 polygons, rectangles, circles, lines, points and VOC/COCO export.")
     (license license:gpl3+)))
+
+(define-public charls
+  (package
+    (name "charls")
+    (version "2.3.4")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/team-charls/charls/")
+                    (commit (string-append version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0g3f1rfimk30rqmi7ic4i5vfphyqbbpsyyhwqq1iss9wjwaz2vs5"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:configure-flags '("-DCMAKE_BUILD_TYPE:STRING=Release"
+                           "-DBUILD_SHARED_LIBS=On")))
+    (native-inputs (list git pkg-config))
+    (home-page "https://github.com/team-charls/charls")
+    (synopsis "Library for using JPEG-LS compliant images")
+    (description
+     "CharLS is a codec library that can be used to build applications that
+can handle JPEG-LS compliant images.  In the application you are writing you
+can call the CharLS codec and pass it images (sometimes called raster bitmaps),
+ to have them encoded to JPEG-LS, or JPEG-LS streams, which CharLS will decode
+to images.")
+    (license license:bsd-3)))