summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-08 11:35:41 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-16 12:44:34 +0100
commit2057f778a449754dcd741d80910dd4fca3f27c63 (patch)
tree34cc412dfcd27c2c2d63ac8236ac3269e8787b32 /gnu/packages
parente2c76bdd8376d3ef26ce74ab42ea1cebee669f1b (diff)
downloadguix-2057f778a449754dcd741d80910dd4fca3f27c63.tar.gz
gnu: python-pypng: Update to 0.20220715.0.
* gnu/packages/python-xyz.scm (python-pypng): Update to 0.20220715.0.
[build-system]: Use pyproject-build-system.
[arguments]: Add 'pre-check phase.
[native-inputs]: Add python-pytest.

Change-Id: Ic47c653f94a688048383eba216f01d7987625680
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm16
1 files changed, 13 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 95e8258a74..d611f52e57 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -28937,14 +28937,24 @@ lowercase.")
 (define-public python-pypng
   (package
     (name "python-pypng")
-    (version "0.0.20")
+    (version "0.20220715.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "pypng" version))
        (sha256
-        (base32 "02qpa22ls41vwsrzw9r9qhj1nhq05p03hb5473pay6y980s86chh"))))
-    (build-system python-build-system)
+        (base32 "1hg24zja235bkbny82hx7sy7qlzfbabxph2lvqaq61vgm4xl773k"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:phases
+      '(modify-phases %standard-phases
+         (add-before 'check 'pre-check
+           (lambda _
+             (setenv "PYTHONPATH"
+                     (string-append (getcwd) "/code:"
+                                    (getenv "GUIX_PYTHONPATH"))))))))
+    (native-inputs (list python-pytest))
     (home-page "https://github.com/drj11/pypng")
     (synopsis "Pure Python PNG image encoder/decoder")
     (description