summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:04:37 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:07:23 +0200
commit24128f38cbcf668828ec9a622e21b03f904bf857 (patch)
treecbbba1c1a6cb75b52e25d761dc2b8eb2a436bbeb /gnu/packages
parent59d2a64002c91133403053085ed2668a690a1560 (diff)
downloadguix-24128f38cbcf668828ec9a622e21b03f904bf857.tar.gz
gnu: Add texlive-vpe.
* gnu/packages/tex.scm (texlive-vpe): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 14312906f1..4eae20cd66 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -99557,6 +99557,30 @@ counters, definitions, index entries etc., are kept consistent throughout the
 input file.")
     (license license:lppl)))
 
+(define-public texlive-vpe
+  (package
+    (name "texlive-vpe")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/vpe/" "scripts/vpe/"
+                   "tex/latex/vpe/")
+             (base32
+              "1mic6ljwfx50rassr1rr8ymqvbiblbpvrcdqkvwbahxxirjdj1xl")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (arguments
+     (list #:link-scripts #~(list "vpe.pl")))
+    (inputs (list perl))
+    (home-page "https://ctan.org/pkg/vpe")
+    (synopsis "Source specials for PDF output")
+    (description
+     "VPE is a system to make the equivalent of source special marks in a PDF
+file.  Clicking on a mark will activate an editor, pointing at the source line
+that produced the text that was marked.  The system comprises a Perl
+file (@file{vpe.pl}) and a LaTeX package (@file{vpe.sty}).")
+    (license license:lppl)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar