summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-08-29 17:31:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2017-08-30 03:24:19 +0200
commit249ab8cc3e8ac01bcb2ef261d0d4b6c2a047e21a (patch)
tree79e0e22971e9e13572372d8545045f55261f146a /gnu/packages
parent3c8ba11a97d3f3b671b8919da8c41f0b0e2ccaf3 (diff)
downloadguix-249ab8cc3e8ac01bcb2ef261d0d4b6c2a047e21a.tar.gz
gnu: nginx: Install man page.
* gnu/packages/web.scm (nginx)[arguments]: Install the nginx(8) man page,
and add a comment about the non-GNU configure script.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/web.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 471cfe9e57..2ad1b6b7a7 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -157,6 +157,7 @@ and its related documentation.")
                (("/bin/sh") (which "sh")))
              #t))
          (replace 'configure
+           ;; The configure script is hand-written, not from GNU autotools.
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((flags
                     (list (string-append "--prefix=" (assoc-ref outputs "out"))
@@ -185,6 +186,12 @@ and its related documentation.")
                (format #t "environment variable `CC' set to `gcc'~%")
                (format #t "configure flags: ~s~%" flags)
                (zero? (apply system* "./configure" flags)))))
+         (add-after 'install 'install-man-page
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (man (string-append out "/share/man")))
+               (install-file "objs/nginx.8" (string-append man "/man8"))
+               #t)))
          (add-after 'install 'fix-root-dirs
            (lambda* (#:key outputs #:allow-other-keys)
              ;; 'make install' puts things in strange places, so we need to