summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-11-21 15:17:12 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-11-21 15:43:23 +0200
commit24a2e19c432580a1a4900417ce81a4826e41e8f4 (patch)
tree3c9be10715cbf0b69b2918dce8911377abd214f2 /gnu/packages
parent4e94cdb652ca30b74ad68153da976827c8ea16a2 (diff)
downloadguix-24a2e19c432580a1a4900417ce81a4826e41e8f4.tar.gz
gnu: python-waf: Use a proper directory structure.
Fixes <https://bugs.gnu.org/25634>.

* gnu/packages/python.scm (python-waf): Replace custom 'install phase to
install "waf" binary into the bin directory. Remove the 'wrap phase.
* gnu/packages/video.scm (mpv)[arguments]: Adjust the 'setup-waf phase
accordingly.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm9
-rw-r--r--gnu/packages/video.scm3
2 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 1e67640763..07ab0e5293 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5607,9 +5607,12 @@ so it might be a tiny bit slower.")
            (lambda _
              (invoke "python" "waf" "--version")))
          (replace 'install
-           (lambda _
-             (copy-file "waf" %output)
-             #t)))))
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out")))
+               (install-file "waf" (string-append out "/bin")))
+             #t))
+         ;; waf breaks when it is wrapped.
+         (delete 'wrap))))
     (home-page "https://waf.io/")
     (synopsis "Python-based build system")
     (description
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index f4e461119b..8a5e730bd5 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1180,7 +1180,8 @@ SVCD, DVD, 3ivx, DivX 3/4/5, WMV and H.264 movies.")
          (add-before
           'configure 'setup-waf
           (lambda* (#:key inputs #:allow-other-keys)
-            (copy-file (assoc-ref inputs "waf") "waf")
+            (let ((waf (assoc-ref inputs "waf")))
+              (copy-file (string-append waf "/bin/waf") "waf"))
             (setenv "CC" "gcc")
             #t)))
        #:configure-flags (list "--enable-libmpv-shared"