summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-07-10 00:37:58 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-07-11 14:27:00 -0400
commit24ffd91bc257a4ebddd8359f4f32c4fb60fc90e1 (patch)
tree01d0b8f22dc7178184f18611fbe1a80ec9cefa12 /gnu/packages
parent908df675a84cfdf80901a1cb25bd83cf576a1a99 (diff)
downloadguix-24ffd91bc257a4ebddd8359f4f32c4fb60fc90e1.tar.gz
gnu: Add ruby-tomparse.
* gnu/packages/ruby.scm (ruby-tomparse): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ruby.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index dd651ddf19..07e23a0113 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7230,6 +7230,29 @@ used, such as Assay or AE.")
     (home-page "http://rubyworks.github.com/spectroscope/")
     (license license:bsd-2)))
 
+(define-public ruby-tomparse
+  (package
+    (name "ruby-tomparse")
+    (version "0.4.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (rubygems-uri "tomparse" version))
+       (sha256
+        (base32
+         "06xakk41f1kgj6j1ahkwn4r6cvidixvm4phhlrvmwb7c3pr8ygc8"))))
+    (build-system ruby-build-system)
+    ;; TODO: Tests require citron and rulebow, not yet packaged.
+    (arguments '(#:tests? #f))
+    (synopsis "TomDoc parser for Ruby")
+    (description "TomParse is a TomDoc parser for Ruby.  It takes a code
+comment as input and parses it into a convenient object-oriented structure in
+accordance with the TomDoc standard.  See
+@url{https://github.com/mojombo/tomdoc, TomDoc} for more information about the
+TomDoc format.")
+    (home-page "http://rubyworks.github.com/tomparse/")
+    (license license:bsd-2)))
+
 (define-public ruby-clap
   (package
     (name "ruby-clap")