summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLeo Nikkilä <hello@lnikki.la>2023-11-27 06:11:21 +0200
committerLudovic Courtès <ludo@gnu.org>2023-12-03 23:55:09 +0100
commit25de8f3c5e10a31db9c9fc0179000cbfe8f6b47a (patch)
tree6a9abe3bf4cdfae00ef0ec54535555913a5d62c0 /gnu/packages
parent9f66582ed0630de5895c77d9e1b8d8bad90f33b1 (diff)
downloadguix-25de8f3c5e10a31db9c9fc0179000cbfe8f6b47a.tar.gz
gnu: kpackage: Work around flaky test.
When parallel tests are enabled, plasma-querytest can fail with:

    5/11 Test  #5: plasma-querytest ....................Subprocess aborted***Exception:   0.02 sec
    ********* Start testing of QueryTest *********
    Config: Using QtTest library 5.15.10, Qt 5.15.10 (arm64-little_endian-lp64 shared (dynamic) release build; by GCC 11.3.0), unknown unknown
    PASS   : QueryTest::initTestCase()
    QFATAL : QueryTest::installAndQuery() QThread: Destroyed while thread is still running
    FAIL!  : QueryTest::installAndQuery() Received a fatal error.
    Loc: [Unknown file(0)]
    Totals: 1 passed, 1 failed, 0 skipped, 0 blacklisted, 3ms
    ********* Finished testing of QueryTest *********

I'm able to consistently reproduce this on an aarch64-linux machine.
`guix build --cores=1' can also work around this.

* gnu/packages/kde-frameworks.scm (kpackage): Work around flaky test.
[arguments]<#:parallel-tests?>: Disable.  Follows what Debian has done.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/kde-frameworks.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 0384baae46..4572d55cb8 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -2028,6 +2028,9 @@ covers feedback and persistent events.")
            qtbase-5))
     (arguments
      (list
+      ;; The `plasma-querytest' test is known to fail when tests are run in parallel:
+      ;; <https://sources.debian.org/src/kpackage/5.107.0-1/debian/changelog/#L92>
+      #:parallel-tests? #f
       #:phases
       #~(modify-phases %standard-phases
           (add-after 'unpack 'patch