summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2020-04-05 21:30:26 +0200
committerJulien Lepiller <julien@lepiller.eu>2020-07-17 04:10:42 +0200
commit29428e10b832e99af70eafdb381a45bd701b3397 (patch)
tree8e618f0163c40af0a624a2c2700ab2c61bbd7fb6 /gnu/packages
parent031516d69a4cd8d4d5c4ed6989b1f5b39eb607c1 (diff)
downloadguix-29428e10b832e99af70eafdb381a45bd701b3397.tar.gz
gnu: java-junit: Enable tests.
* gnu/packages/java.scm (java-junit)[arguments]: Enable tests.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/java.scm17
1 files changed, 14 insertions, 3 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index a3781a2da5..c74afa726b 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -3733,10 +3733,21 @@ testing frameworks, mocking libraries and UI validation rules.")
                   #t))))
     (build-system ant-build-system)
     (arguments
-     `(#:tests? #f ; no tests
-       #:jar-name "junit.jar"))
-    (inputs
+     `(#:jar-name "junit.jar"
+       #:source-dir "src/main/java"
+       #:test-dir "src/test"
+       #:test-exclude (list "**/SimpleTest.java" "**/StackTracesTest.java"
+                            "**/RuleChainTest.java" "**/TestWatchmanTest.java")
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'check 'copy-test-resources
+           (lambda _
+             (copy-recursively "src/test/resources" "build/test-classes")
+             #t)))))
+    (propagated-inputs
      `(("java-hamcrest-core" ,java-hamcrest-core)))
+    (native-inputs
+     `(("java-hamcrest-library" ,java-hamcrest-library)))
     (home-page "https://junit.org/junit4/")
     (synopsis "Test framework for Java")
     (description