summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-01-03 00:43:04 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-01-13 01:25:16 +0100
commit2bb187c4844c248c66472eacef0570bc7c92e1fe (patch)
tree39c49456bdfe43e1bef85fb2c3365f1618169b25 /gnu/packages
parent0c4cee13b26a953e54f47da081e1f461b46c1976 (diff)
downloadguix-2bb187c4844c248c66472eacef0570bc7c92e1fe.tar.gz
gnu: xscreensaver: Update to 5.42.
* gnu/packages/xdisorg.scm (xscreensaver): Update to 5.42.
[arguments]: Add "CFLAGS=-std=c99" to #:make-flags.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/xdisorg.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index fdfa1511d8..b64094ed18 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -992,7 +992,7 @@ color temperature should be set to match the lamps in your room.")
 (define-public xscreensaver
   (package
     (name "xscreensaver")
-    (version "5.40")
+    (version "5.42")
     (source
      (origin
        (method url-fetch)
@@ -1001,7 +1001,7 @@ color temperature should be set to match the lamps in your room.")
                        version ".tar.gz"))
        (sha256
         (base32
-         "1q2sr7h6ps6d3hk8895g12rrcqiihjl7py1ly077ikv4866r181h"))))
+         "1qfbsnj7201d03vf0b2lzxmlcq4kvkvzp48r5gcgsjr17c1sl7a4"))))
     (build-system gnu-build-system)
     (arguments
      `(#:tests? #f  ; no check target
@@ -1015,7 +1015,9 @@ color temperature should be set to match the lamps in your room.")
              #t)))
        #:configure-flags '("--with-pam" "--with-proc-interrupts"
                            "--without-readdisplay")
-       #:make-flags (list (string-append "AD_DIR="
+       ;; FIXME: Remove CFLAGS once our default compiler is GCC6 or later.
+       #:make-flags (list "CFLAGS=-std=c99"
+                          (string-append "AD_DIR="
                                          (assoc-ref %outputs "out")
                                          "/usr/lib/X11/app-defaults"))))
     (native-inputs