summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-07-30 10:34:14 +0200
committerDavid Craven <david@craven.ch>2016-08-05 21:48:43 +0200
commit2f04282297367b73bb34e3f1d39802d765c613e9 (patch)
tree31488f84c7849d1038a7e02c3416c5e34c93859c /gnu/packages
parent8ff4dcbec46a818275541880b36e9a004899506a (diff)
downloadguix-2f04282297367b73bb34e3f1d39802d765c613e9.tar.gz
gnu: qemu: Reorder inputs alphabetically.
* gnu/packages/qemu.scm (qemu): Reorder inputs alphabetically.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/qemu.scm37
1 files changed, 18 insertions, 19 deletions
diff --git a/gnu/packages/qemu.scm b/gnu/packages/qemu.scm
index 911ed4c8cc..6b5a41b411 100644
--- a/gnu/packages/qemu.scm
+++ b/gnu/packages/qemu.scm
@@ -118,29 +118,28 @@
                 (string-append "# " all)))
              #t)))))
     (inputs                                       ; TODO: Add optional inputs.
-     `(("sdl" ,sdl)
-       ("mesa" ,mesa)
-       ("libusb" ,libusb)                         ;USB pass-through support
-
-       ;; ("libaio" ,libaio)
+     `(("alsa-lib" ,alsa-lib)
+       ("attr" ,attr)
        ("glib" ,glib)
-       ("ncurses" ,ncurses)
-       ("libpng" ,libpng)
+       ;; ("libaio" ,libaio)
+       ("libattr" ,attr)
+       ("libcap" ,libcap)           ; virtfs support requires libcap & libattr
        ("libjpeg" ,libjpeg-8)
+       ("libpng" ,libpng)
+       ("libusb" ,libusb)                         ;USB pass-through support
+       ("mesa" ,mesa)
+       ("ncurses" ,ncurses)
+       ;; ("pciutils" ,pciutils)
        ("pixman" ,pixman)
-       ;; ("vde2" ,vde2)
+       ("sdl" ,sdl)
        ("util-linux" ,util-linux)
-       ("libcap" ,libcap)           ; virtfs support requires libcap & libattr
-       ("libattr" ,attr)
-       ;; ("pciutils" ,pciutils)
-       ("alsa-lib" ,alsa-lib)
-       ("zlib" ,zlib)
-       ("attr" ,attr)))
-    (native-inputs `(("pkg-config" ,pkg-config)
+       ;; ("vde2" ,vde2)
+       ("zlib" ,zlib)))
+    (native-inputs `(("glib:bin" ,glib "bin") ; gtester, etc.
+                     ("perl" ,perl)
+                     ("pkg-config" ,pkg-config)
                      ("python" ,python-2) ; incompatible with Python 3 according to error message
-                     ("glib" ,glib "bin") ; gtester, etc.
-                     ("texinfo" ,texinfo)
-                     ("perl" ,perl)))
+                     ("texinfo" ,texinfo)))
     (home-page "http://www.qemu-project.org")
     (synopsis "Machine emulator and virtualizer")
     (description
@@ -175,4 +174,4 @@ server and embedded PowerPC, and S390 guests.")
 
     ;; Remove dependencies on optional libraries, notably GUI libraries.
     (inputs (fold alist-delete (package-inputs qemu)
-                  '("sdl" "mesa" "libusb")))))
+                  '("libusb" "mesa" "sdl")))))