summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorKei Kebreau <kei@openmailbox.org>2017-05-10 08:23:31 -0400
committerMarius Bakke <mbakke@fastmail.com>2017-05-14 17:30:09 +0200
commit31860852cd5fcdb12ab42d638512cb4ff701e63c (patch)
tree5c9d1557734d20d9e656c6a7b2ba0204954cc1e3 /gnu/packages
parent982b35747854f7be35700572ec75e45881fa55e2 (diff)
downloadguix-31860852cd5fcdb12ab42d638512cb4ff701e63c.tar.gz
gnu: cogl: Enable wayland support.
* gnu/packages/gnome.scm (cogl)[inputs]: Add wayland.
[arguments]: Add "--enable-wayland-egl-platform" and
"--enable-wayland-egl-server".
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gnome.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index c4ab5feb98..e98a5523b3 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2935,9 +2935,13 @@ throughout GNOME for API documentation).")
        ("cairo" ,cairo)
        ("pango" ,pango)
        ("gstreamer" ,gstreamer)
-       ("gst-plugins-base" ,gst-plugins-base)))
+       ("gst-plugins-base" ,gst-plugins-base)
+       ("wayland" ,wayland)))
     (arguments
      `(#:configure-flags (list "--enable-cogl-gst"
+                               "--enable-wayland-egl-platform"
+                               "--enable-wayland-egl-server"
+
                                ;; Arrange to pass an absolute file name to
                                ;; dlopen for libGL.so.
                                (string-append "--with-gl-libname="