summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-16 17:15:34 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:36 +0200
commit31db747769a36127eb47c3ba4ebaef3315f1856f (patch)
tree5550d764561dbfe1829a0fd038b9546e9ddd4539 /gnu/packages
parentcd54081a19f839134ca757301a0e785b672ba633 (diff)
downloadguix-31db747769a36127eb47c3ba4ebaef3315f1856f.tar.gz
gnu: Add texlive-latexfileversion.
* gnu/packages/tex.scm (texlive-latexfileversion): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 29da870f97..758248786f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2643,6 +2643,26 @@ used to override this default behaviour and accept or reject selected changes
 only.")
     (license license:gpl3)))
 
+(define-public texlive-latexfileversion
+  (package
+    (name "texlive-latexfileversion")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/support/latexfileversion/"
+                   "scripts/latexfileversion/")
+             (base32
+              "12kw9s415dnlaadx6yn2jddvflvbs754rkz30xhr3di2ldpvp2jj")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (arguments (list #:link-scripts #~(list "latexfileversion")))
+    (home-page "https://ctan.org/pkg/latexfileversion")
+    (synopsis "Prints the version and date of a LaTeX class or style file")
+    (description
+     "This simple shell script prints the version and date of a LaTeX class or
+style file.")
+    (license license:lppl)))
+
 (define-public texlive-tex-ini-files
   (package
     (name "texlive-tex-ini-files")