summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2019-07-30 19:27:47 -0500
committerEric Bavier <bavier@member.fsf.org>2019-07-30 19:27:47 -0500
commit33d13088d0d0d558a3c002718f8d1962fb160e9c (patch)
tree29cf7044011c599c4cd0a904de3780af803aa8aa /gnu/packages
parent595d4ab163163a6671521251b02a2fbd2e2f81c8 (diff)
downloadguix-33d13088d0d0d558a3c002718f8d1962fb160e9c.tar.gz
gnu: netsurf: Update to 3.9.
* gnu/packages/web.scm (netsurf)[source]: Update to 3.9.
[native-inputs]: Add "xxd" input.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/web.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 17b611a56d..05bf2c10b8 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -127,6 +127,7 @@
   #:use-module (gnu packages tls)
   #:use-module (gnu packages valgrind)
   #:use-module (gnu packages version-control)
+  #:use-module (gnu packages vim)
   #:use-module (gnu packages xml))
 
 (define-public httpd
@@ -4586,7 +4587,7 @@ w3c webidl files and a binding configuration file.")
 (define-public netsurf
   (package
     (name "netsurf")
-    (version "3.8")
+    (version "3.9")
     (source
      (origin
        (method url-fetch)
@@ -4594,7 +4595,7 @@ w3c webidl files and a binding configuration file.")
                            "releases/source/netsurf-" version "-src.tar.gz"))
        (sha256
         (base32
-         "0hjm1h4m1i913y4mhkl7yqdifn8k70fwi58zdh6faypawzryc3m0"))
+         "1hzcm2s2wh5sapgr000lg63hcdbj6hyajxl43xa1x80kc5piqbyp"))
        (patches (search-patches "netsurf-system-utf8proc.patch"
                                 "netsurf-y2038-tests.patch"
                                 "netsurf-longer-test-timeout.patch"
@@ -4607,7 +4608,8 @@ w3c webidl files and a binding configuration file.")
        ("check" ,check)
        ("perl" ,perl)
        ("perl-html-parser" ,perl-html-parser)
-       ("pkg-config" ,pkg-config)))
+       ("pkg-config" ,pkg-config)
+       ("xxd" ,xxd)))
     (inputs
      `(("curl" ,curl)
        ("gtk+" ,gtk+-2)