summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-08-26 18:04:43 +0200
committerJulien Lepiller <julien@lepiller.eu>2018-09-01 23:09:06 +0200
commit37296113799dfadc81a5606d5dace89b406403d8 (patch)
treeb63aadb1d25ba8c9a5e7df103d22cd9861b3e2f7 /gnu/packages
parent49395112c43e62605a75dd02fcce688deb2d5f67 (diff)
downloadguix-37296113799dfadc81a5606d5dace89b406403d8.tar.gz
gnu: Add ruby-pathutil.
* gnu/packages/ruby.scm (ruby-pathutil): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ruby.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 3395cc6aa2..5d8a8873e4 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5844,3 +5844,28 @@ to load dynamic content on storefronts.")
     (description "Forwardable Extended provides more @code{Forwardable}
 methods for your source as @code{Forwardable::Extended}.")
     (license license:expat)))
+
+(define-public ruby-pathutil
+  (package
+    (name "ruby-pathutil")
+    (version "0.16.1")
+    (source (origin
+              (method url-fetch)
+              (uri (rubygems-uri "pathutil" version))
+              (sha256
+               (base32
+                "0wc18ms1rzi44lpjychyw2a96jcmgxqdvy2949r4vvb5f4p0lgvz"))))
+    (build-system ruby-build-system)
+    (propagated-inputs
+     `(("ruby-forwardable-extended" ,ruby-forwardable-extended)))
+    (native-inputs
+     `(("bundler" ,bundler)
+       ("ruby-rspec" ,ruby-rspec)))
+    ;; Fails with: cannot load such file --
+    ;; /tmp/guix-build-ruby-pathutil-0.16.0.drv-0/gem/benchmark/support/task
+    (arguments `(#:tests? #f))
+    (home-page "https://github.com/envygeeks/pathutil")
+    (synopsis "Extended implementation of Pathname")
+    (description "Pathutil tries to be a faster pure Ruby implementation of
+Pathname.")
+    (license license:expat)))