summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-08-15 22:23:13 +0200
committerMarius Bakke <marius@gnu.org>2022-08-16 00:43:43 +0200
commit389ae75a37b4238c8efa8577cd860e37e35a961e (patch)
tree3874ad3935a3629543bb28d61ad7af28cbee159c /gnu/packages
parent7e0116740b8d93ccd0d6d760dc89cbdc65598119 (diff)
downloadguix-389ae75a37b4238c8efa8577cd860e37e35a961e.tar.gz
gnu: python-lz4: Update to 4.0.2.
* gnu/packages/python-compression.scm (python-lz4): Update to 4.0.2.
[native-inputs]: Remove PYTHON-NOSE.  Add PYTHON-PKGCONFIG and PYTHON-PSUTIL.
[arguments]: Override check phase.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-compression.scm18
1 files changed, 14 insertions, 4 deletions
diff --git a/gnu/packages/python-compression.scm b/gnu/packages/python-compression.scm
index edfa974a71..12c172c0bc 100644
--- a/gnu/packages/python-compression.scm
+++ b/gnu/packages/python-compression.scm
@@ -5,7 +5,7 @@
 ;;; Copyright © 2017 Julien Lepiller <julien@lepiller.eu>
 ;;; Copyright © 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
-;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2020, 2022 Marius Bakke <marius@gnu.org>
 ;;; Copyright © 2021 Brendan Tildesley <mail@brendan.scot>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -230,14 +230,14 @@ Python strings.")
 (define-public python-lz4
   (package
     (name "python-lz4")
-    (version "0.10.1")
+    (version "4.0.2")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "lz4" version))
        (sha256
         (base32
-         "0ghv1xbaq693kgww1x9c22bplz479ls9szjsaa4ig778ls834hm0"))
+         "16vj2bnhhdkcz2a2ai2mx2kf9ngx1cjr18636yp1514kq9r72fq8"))
        (modules '((guix build utils)))
        (snippet
         '(begin
@@ -245,8 +245,18 @@ Python strings.")
            (delete-file-recursively "lz4libs")
            #t))))
     (build-system python-build-system)
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (replace 'check
+                 (lambda* (#:key tests? #:allow-other-keys)
+                   (when tests?
+                     ;; Taken from tox.ini (excludes experimental tests).
+                     (invoke "pytest" "-vv" "tests/block" "tests/frame")))))))
     (native-inputs
-     (list pkg-config python-nose python-setuptools-scm))
+     (list pkg-config python-pytest python-pkgconfig python-setuptools-scm
+           ;; For tests.
+           python-psutil))
     (inputs
      (list lz4))
     (home-page "https://github.com/python-lz4/python-lz4")