summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-03-01 00:58:14 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-03-19 00:56:23 +0100
commit3a68cf2b96b5bb89be9c083b1770285bfadca41a (patch)
treea0511017617e7173bafc8d300541e550e681856c /gnu/packages
parent465259be78600d17d83f0cee6b06b8a83babda16 (diff)
downloadguix-3a68cf2b96b5bb89be9c083b1770285bfadca41a.tar.gz
gnu: Add go-github-com-schachmat-ingo.
* gnu/packages/golang.scm (go-github-com-schachmat-ingo): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 705b803599..a8b845e301 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1158,6 +1158,28 @@ terminals.")
 proxy protocol.")
     (license license:asl2.0)))
 
+(define-public go-github-com-schachmat-ingo
+  (package
+    (name "go-github-com-schachmat-ingo")
+    (version "0.0.0-20170403011506-a4bdc0729a3f")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/schachmat/ingo")
+               (commit (go-version->git-ref version))))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32 "1gw0kddy7jh3467imsqni86cf9yq7k6vpfc0ywkbwj0zsjsdgd49"))))
+    (build-system go-build-system)
+    (arguments '(#:import-path "github.com/schachmat/ingo"))
+    (home-page "https://github.com/schachmat/ingo")
+    (synopsis "Go library to persist flags in a INI-like configuration file")
+    (description
+      "Ingo is a Go library helping you to persist flags in a INI-like
+configuration file.")
+    (license license:isc)))
+
 (define-public go-github-com-riobard-go-bloom
   (let ((commit "cdc8013cb5b3eb0efebec85f0e904efccac42df9")
         (revision "0"))