summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-01-19 22:58:01 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-01-25 00:33:57 +0300
commit3cf3836244c4fc49ff4d4513509b9d9f55ceda66 (patch)
tree75023f61433f7078e967259b753b50d9c08b6d84 /gnu/packages
parent6b113dad78c383cf9e158ebb2a06900e112217a8 (diff)
downloadguix-3cf3836244c4fc49ff4d4513509b9d9f55ceda66.tar.gz
gnu: Add python-iso639.
* gnu/packages/iso-codes.scm (python-iso639): New public variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/iso-codes.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/iso-codes.scm b/gnu/packages/iso-codes.scm
index ccd07706c5..929bb58268 100644
--- a/gnu/packages/iso-codes.scm
+++ b/gnu/packages/iso-codes.scm
@@ -23,6 +23,7 @@
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
+  #:use-module (guix build-system python)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages python))
@@ -64,3 +65,25 @@ infrastructure.  Moreover, the programmer does not need to follow
 changes in the ISO standard and will not work with outdated
 information.")
     (license license:gpl2+)))           ; some bits use the lgpl2
+
+(define-public python-iso639
+  (package
+    (name "python-iso639")
+    (version "0.4.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "iso-639" version))
+       (sha256
+        (base32
+         "0jffmh4m20q8j27xb2fqbnlghjj0cx8pgsbzqisdg65qh2wd976w"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/noumar/iso639")
+    (synopsis "Python library for ISO 639 standard")
+    (description "This package provides a Python library for ISO 639 standard
+that is concerned with representation of names for languages and language
+groups.")
+    (license license:agpl3+)))
+
+(define-public python2-iso639
+  (package-with-python2 python-iso639))