summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorPierre Neidhardt <ambrevar@gmail.com>2018-08-14 10:41:08 +0200
committerPierre Neidhardt <ambrevar@gmail.com>2018-08-14 10:41:08 +0200
commit3d4908a77b3c557418d95152edb2f1bff93bf09d (patch)
tree44d4dd57d3a8106204e62859450b21e59eb7749f /gnu/packages
parent9285f8bbae9d71139873430c71b7ca7634bda31b (diff)
downloadguix-3d4908a77b3c557418d95152edb2f1bff93bf09d.tar.gz
gnu: texlive-latex-l3packages: Fix missing files.
* gnu/packages/tex.scm (texlive-latex-l3packages): Actually install the files.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e33a98a9fd..4a0a4faccb 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1432,6 +1432,9 @@ that the LaTeX3 conventions can be used with regular LaTeX 2e packages.")
     (build-system texlive-build-system)
     (arguments
      '(#:tex-directory "latex/l3packages"
+       ;; build-targets must be specified manually since they are in
+       ;; sub-directories.
+       #:build-targets '("l3keys2e.ins" "xparse.ins" "xfrac.ins" "xfp.ins" "xtemplate.ins")
        #:phases
        (modify-phases %standard-phases
          ;; All package sources are in sub-directories, so we need to add them
@@ -1444,8 +1447,12 @@ that the LaTeX3 conventions can be used with regular LaTeX 2e packages.")
                                       cwd "/xparse:"
                                       cwd "/xfrac:"
                                       cwd "/xfp:"
-                                      cwd "/xtemplate")))
-             #t)))))
+                                      cwd "/xtemplate"
+                                      ;; The terminating ":" is required to include the
+                                      ;; l3kernel input as well.
+                                      ":")))
+             #t)))
+       ))
     (inputs
      `(("texlive-latex-l3kernel" ,texlive-latex-l3kernel)))
     (home-page "https://www.ctan.org/pkg/l3packages")