summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-11-27 19:26:18 +0100
committerMarius Bakke <marius@gnu.org>2022-11-27 21:19:51 +0100
commit3ecd59f08cb1371077472b01f12a8d389bb210bd (patch)
tree09aad0167db1a66f920d5e69c609c1f6a90bee26 /gnu/packages
parenta9956536f37f6467389941aaac57b503eeeda665 (diff)
downloadguix-3ecd59f08cb1371077472b01f12a8d389bb210bd.tar.gz
gnu: QtWebEngine: Propagate required dependencies.
* gnu/packages/qt.scm (qtwebengine-5)[inputs]: Move QTBASE-5, QTDECLARATIVE-5,
and QTWEBCHANNEL-5 ...
[propagated-inputs]: ... here.
(qtwebengine)[inputs, propagated-inputs]: Adjust accordingly.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/qt.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 7694334a2c..a0ced6451b 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2579,16 +2579,16 @@ using the Enchant spell-checking library.")
            pciutils
            protobuf
            pulseaudio
-           qtbase-5
-           qtdeclarative-5
            qtmultimedia-5
-           qtwebchannel-5
            re2
            snappy
            eudev
            valgrind
            vulkan-headers
            xcb-util))
+    (propagated-inputs
+     ;; Required by Qt5WebEngineCoreConfig.cmake.
+     (list qtbase-5 qtdeclarative-5 qtwebchannel-5))
     (arguments
      (substitute-keyword-arguments (package-arguments qtsvg-5)
        ((#:modules modules '())
@@ -2983,11 +2983,13 @@ linux/libcurl_wrapper.h"
                python-html5lib)))
     (inputs
      (modify-inputs (package-inputs qtwebengine-5)
-       (replace "qtbase" qtbase)
-       (replace "qtdeclarative" qtdeclarative)
        (replace "qtmultimedia" qtmultimedia)
-       (replace "qtwebchannel" qtwebchannel)
        (append libxkbfile xkeyboard-config)))
+    (propagated-inputs
+     (modify-inputs (package-propagated-inputs qtwebengine-5)
+       (replace "qtbase" qtbase)
+       (replace "qtdeclarative" qtdeclarative)
+       (replace "qtwebchannel" qtwebchannel)))
     (native-search-paths
      (list (search-path-specification
             (file-type 'regular)