summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-10-01 16:21:30 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-10-02 11:00:05 +0000
commit40e07889d13ad447f8f79060a4b0c6d8febe3959 (patch)
treec260d58750fc0d38084381a1f8b3333b2d9fd5e0 /gnu/packages
parent9c96dfd43cb8e4fdfcc61554cf9825b58f370a49 (diff)
downloadguix-40e07889d13ad447f8f79060a4b0c6d8febe3959.tar.gz
gnu: avahi: Make the 'patch-more-shebangs' phase unconditional.
* gnu/packages/avahi.scm (avahi)[arguments]<#:phases>{patch-more-shebangs}:
  Make it unconditional.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/avahi.scm27
1 files changed, 12 insertions, 15 deletions
diff --git a/gnu/packages/avahi.scm b/gnu/packages/avahi.scm
index 20c0f2708e..797e35e7eb 100644
--- a/gnu/packages/avahi.scm
+++ b/gnu/packages/avahi.scm
@@ -75,21 +75,18 @@
                            ,@(if (%current-target-system)
                                  '("ac_cv_prog_have_pkg_config=yes")
                                  '()))
-       ;; TODO(core-updates): Make this unconditional.
-       ,@(if (%current-target-system)
-             `(#:modules ((srfi srfi-26)
-                          (guix build utils)
-                          (guix build gnu-build-system))
-               #:phases
-               ,#~(modify-phases %standard-phases
-                    (add-after 'patch-shebangs 'patch-more-shebangs
-                      (lambda* (#:key inputs #:allow-other-keys)
-                        (define path
-                          `(,(dirname (search-input-file inputs "bin/sh"))))
-                        (for-each
-                         (cut patch-shebang <> path)
-                         (find-files (string-append #$output "/etc/avahi")))))))
-             '())))
+       #:modules ((srfi srfi-26)
+                  (guix build utils)
+                  (guix build gnu-build-system))
+       #:phases
+       ,#~(modify-phases %standard-phases
+            (add-after 'patch-shebangs 'patch-more-shebangs
+              (lambda* (#:key inputs #:allow-other-keys)
+                (define path
+                  `(,(dirname (search-input-file inputs "bin/sh"))))
+                (for-each
+                 (cut patch-shebang <> path)
+                 (find-files (string-append #$output "/etc/avahi"))))))))
     (inputs
      `(("bash-minimal" ,bash-minimal)
        ("dbus" ,dbus)