summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2017-12-10 12:50:26 -0500
committerLudovic Courtès <ludo@gnu.org>2017-12-11 17:14:36 +0100
commit42e891c27bccb32f51094c2c5cf85d5b4e5e6500 (patch)
tree49fcb54e105f48a6362e16db2de13a1e45bd40d7 /gnu/packages
parent73138fd146a1449df77ee26cc5717b18cb15d84a (diff)
downloadguix-42e891c27bccb32f51094c2c5cf85d5b4e5e6500.tar.gz
gnu: Add emacs-diff-hl.
* gnu/packages/emacs.scm (emacs-diff-hl): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 781a387a41..fd03056292 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -5084,6 +5084,28 @@ you'd get with @kbd{M-q} using @code{adaptive-fill-mode}, but without
 actually changing the buffer's text.")
     (license license:gpl3+)))
 
+(define-public emacs-diff-hl
+ (package
+  (name "emacs-diff-hl")
+  (version "1.8.4")
+  (source
+    (origin
+      (method url-fetch)
+      (uri (string-append "http://elpa.gnu.org/packages/diff-hl-"
+                          version ".tar"))
+      (sha256
+        (base32
+          "0axhidc3cym7a2x4rpxf4745qss9s9ajyg4s9h5b4zn7v7fyp71n"))))
+  (build-system emacs-build-system)
+  (home-page "https://github.com/dgutov/diff-hl")
+  (synopsis
+    "Highlight uncommitted changes using VC")
+  (description
+    "@code{diff-hl-mode} highlights uncommitted changes on the side of the
+window (using the fringe, by default), allows you to jump between
+the hunks and revert them selectively.")
+  (license license:gpl3+)))
+
 (define-public emacs-diminish
   (package
     (name "emacs-diminish")