summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-02-15 21:43:01 +0100
committerRicardo Wurmus <rekado@elephly.net>2015-02-16 20:12:33 +0100
commit4443bb8da3ddaa13ec86b4b0b75e739d4ca09b03 (patch)
tree0ec8932312ebdd67c8cd7e86059cbaf923cda0f2 /gnu/packages
parente926ba716e96f22fb6c3afa97340b38f89127315 (diff)
downloadguix-4443bb8da3ddaa13ec86b4b0b75e739d4ca09b03.tar.gz
gnu: Add patchage.
* gnu/packages/audio.scm (patchage): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/audio.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 4e87fef7b3..eba08530f8 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -415,6 +415,40 @@ extensions into easy to use C++ classes.  It is the successor of
 lv2-c++-tools.")
     (license license:gpl3+)))
 
+(define-public patchage
+  (package
+    (name "patchage")
+    (version "1.0.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://download.drobilla.net/patchage-"
+                                  version
+                                  ".tar.bz2"))
+              (sha256
+               (base32
+                "1agdpwwi42176l4mxj0c4fsvdiv1ig56bfnnx0msckxmy57df8bb"))))
+    (build-system waf-build-system)
+    (arguments `(#:tests? #f)) ; no check target
+    (inputs
+     `(("alsa-lib" ,alsa-lib)
+       ("boost" ,boost)
+       ("jack" ,jack-1)
+       ("libuuid" ,util-linux)
+       ("ganv" ,ganv)
+       ("glib" ,glib)
+       ("glibmm" ,glibmm)
+       ("gtkmm" ,gtkmm-2)
+       ("dbus" ,dbus)
+       ("dbus-glib" ,dbus-glib)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "http://drobilla.net/software/patchage/")
+    (synopsis "Modular patch bay for audio and MIDI systems")
+    (description
+     "Patchage is a modular patch bay for audio and MIDI systems based on JACK
+and ALSA.")
+    (license license:gpl3+)))
+
 (define-public rubberband
   (package
     (name "rubberband")