summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-16 11:07:54 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:51 +0000
commit47993ad90007897ac008348e3f9ecb9cd6856b6e (patch)
treeaeab8d27e048ae551b35a3cccbd0b332c643493f /gnu/packages
parente05d3eabd240fa29b32529284c328f5b027a57f2 (diff)
downloadguix-47993ad90007897ac008348e3f9ecb9cd6856b6e.tar.gz
gnu: nebula: Fix build.
* gnu/packages/networking.scm (nebula): Fix build.
[arguments]: <#:phases>: Add 'fix-embed-files.

Change-Id: Ie2522c61aa1febadd250b1c02738c48bb82497e9
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/networking.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 6e3a355bd4..8cd49992ec 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -4779,6 +4779,24 @@ IPv6 Internet connectivity - it also works over IPv4.")
       #:install-source? #f
       #:phases
       #~(modify-phases %standard-phases
+          ;; TODO: Implement it in go-build-system.
+          ;;
+          ;; This happens due to Golang can't determine the valid directory of
+          ;; the module of embed file which is symlinked during setup
+          ;; environment phase, but easy resolved after coping file from the
+          ;; store to the build directory of the current package, see details
+          ;; in Golang source:
+          ;;
+          ;; - URL: <https://github.com/golang/go/blob/>
+          ;; - commit: 82c14346d89ec0eeca114f9ca0e88516b2cda454
+          ;; - file: src/cmd/go/internal/load/pkg.go#L2059
+          (add-after 'unpack 'fix-embed-files
+            (lambda _
+              (for-each (lambda (file)
+                          (let ((file-store-path (readlink file)))
+                            (delete-file file)
+                            (copy-recursively file-store-path file)))
+                        (find-files "src" ".*(editions_defaults.binpb)$"))))
           (replace 'build
             (lambda* (#:key import-path #:allow-other-keys)
               ;; Suggested option to provide build time flags is not supported