summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2024-05-16 11:41:59 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:03 +0200
commit49c35eec114c20500d0d5eb6cc2e121f3bbd18eb (patch)
treeca4622f8a609f52aa78544a3ab331887e20fa5a0 /gnu/packages
parent2f8fb69a55fa9a5bff008d901c36eea8a8294730 (diff)
downloadguix-49c35eec114c20500d0d5eb6cc2e121f3bbd18eb.tar.gz
gnu: nss-certs: Ungraft update to 3.99.
* gnu/packages/certs.scm (nss-certs): Update to 3.99.
(nss-certs-3.99): Remove variable.

Change-Id: Ie44b6c6d0753abf4db9005b4c0ee48bc6168caa7
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/certs.scm22
1 files changed, 3 insertions, 19 deletions
diff --git a/gnu/packages/certs.scm b/gnu/packages/certs.scm
index 00c6a93b92..449be0b35a 100644
--- a/gnu/packages/certs.scm
+++ b/gnu/packages/certs.scm
@@ -128,10 +128,10 @@ that was originally contributed to Debian.")
 (define-public nss-certs
   (package
     (name "nss-certs")
-    ;; XXX We used to refer to the nss package here, but that eventually caused
+    ;; FIXME We used to refer to the nss package here, but that eventually caused
     ;; module cycles.  The below is a quick copy-paste job that must be kept in
     ;; sync manually.  Surely there's a better way…?
-    (version "3.88.1")
+    (version "3.99")
     (source (origin
               (method url-fetch)
               (uri (let ((version-with-underscores
@@ -142,7 +142,7 @@ that was originally contributed to Debian.")
                       "nss-" version ".tar.gz")))
               (sha256
                (base32
-                "15il9fsmixa1r4446zq1wl627sg0hz9h67w6kjxz273xz3nl7li7"))
+                "1g89ig40gfi1sp02gybvl2z818lawcnrqjzsws36cdva834c5maw"))
               ;; Create nss.pc and nss-config.
               (patches (search-patches "nss-3.56-pkgconfig.patch"
                                        "nss-getcwd-nonnull.patch"
@@ -188,22 +188,6 @@ taken from the NSS package and thus ultimately from the Mozilla project.")
     (home-page "https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSS")
     (license license:mpl2.0)))
 
-(define-public nss-certs-3.99
-  (package
-    (inherit nss-certs)
-    (version "3.99")
-    (source (origin
-              (method url-fetch)
-              (uri (let ((version-with-underscores
-                          (string-join (string-split version #\.) "_")))
-                     (string-append
-                      "https://ftp.mozilla.org/pub/mozilla.org/security/nss/"
-                      "releases/NSS_" version-with-underscores "_RTM/src/"
-                      "nss-" version ".tar.gz")))
-              (sha256
-               (base32
-                "1g89ig40gfi1sp02gybvl2z818lawcnrqjzsws36cdva834c5maw"))))))
-
 (define-public le-certs
   (package
     (name "le-certs")