summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2017-08-30 17:11:52 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-08-30 17:32:00 +0200
commit4a7d2009c858391ec57ee571468b13fb3fdeab52 (patch)
tree2b507a76c4a6a4fec62c245db94d7e5949f12bbc /gnu/packages
parentbeed6abc1dcdd4d373946d18b548e7f148ba0a0f (diff)
downloadguix-4a7d2009c858391ec57ee571468b13fb3fdeab52.tar.gz
gnu: Add python-spectra.
* gnu/packages/python.scm (python-spectra, python2-spectra): New variables.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 921937e1a1..65c1c23b81 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3798,6 +3798,47 @@ objects.")
 (define-public python2-colormath
   (package-with-python2 python-colormath))
 
+(define-public python-spectra
+  (package
+    (name "python-spectra")
+    (version "0.0.8")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "spectra" version))
+       (sha256
+        (base32
+         "0n87kzhpkml2s2q91rdkl8wz2kkv5b0bkrgww45lxa5vq34qh6w5"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda _
+             (zero? (system* "nosetests" "-v")))))))
+    (propagated-inputs
+     `(("python-colormath" ,python-colormath)))
+    (native-inputs
+     `(("python-nose" ,python-nose)))
+    (home-page "http://github.com/jsvine/spectra")
+    (synopsis "Color scales and color conversion")
+    (description
+     "This package provides a Python library intended to make color math,
+color scales, and color space conversion easy.  It has support for:
+
+@enumerate
+@item Color scales
+@item Color ranges
+@item Color blending
+@item Brightening/darkening colors
+@item Saturating/desaturating colors
+@item Conversion to/from multiple color spaces.
+@end enumerate\n")
+    (license license:expat)))
+
+(define-public python2-spectra
+  (package-with-python2 python-spectra))
+
 (define-public python2-fastlmm
   (package
     (name "python2-fastlmm")