summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:04:02 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:07:11 +0200
commit4cb07af4c9c6d75395beed2eb4d9a4cfd27d2210 (patch)
treefad590b98156896ab1201b0ca1323fc1a2a0ffe2 /gnu/packages
parent5d3e43e9b6f2c523db83e00a73663554fb4575a6 (diff)
downloadguix-4cb07af4c9c6d75395beed2eb4d9a4cfd27d2210.tar.gz
gnu: Add texlive-uni-titlepage.
* gnu/packages/tex.scm (texlive-uni-titlepage): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 5f2efbf710..dabd474652 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -98923,6 +98923,31 @@ decorations (such as braces) at arbirary positions over and under expressions,
 overlapping as necessary.")
     (license license:lppl1.3+)))
 
+(define-public texlive-uni-titlepage
+  (package
+    (name "texlive-uni-titlepage")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/uni-titlepage/"
+                   "source/latex/uni-titlepage/"
+                   "tex/latex/uni-titlepage/")
+             (base32
+              "047092jnshnnhy2axqpxh0x0lzaz1dkk9k8gy1vdgwimigzxxn9a")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/uni-titlepage")
+    (synopsis
+     "Universal titlepages with configuration options and predefined styles")
+    (description
+     "Creation of title pages is something most authors should not have to do.  But
+reality is not perfect, so a lot of authors have to do it.  This package not
+only provides several pages for the title instead of only one --- at least
+five are typical for a thesis! ---, it also provides a bunch of predefined
+titlepage styles with several standard elements, and optionally additional
+elements.")
+    (license license:lppl1.3c)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar