summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-12-17 14:32:34 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-12-18 08:14:16 +0200
commit502bb9681b80f31d3c579462c863aae32a620c40 (patch)
treeabc5a551c8e0ec85c315f8c1b698945112d0feeb /gnu/packages
parent1a9f267f51f97b8ca7049aa72763ddd64aad5b62 (diff)
downloadguix-502bb9681b80f31d3c579462c863aae32a620c40.tar.gz
gnu: Remove newsboat-2.13.
* gnu/packages/syndication.scm (newsboat-2.13): Delete variable.

Change-Id: I4453693485a45aee9ba93657624a6e7518808dc8
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/syndication.scm33
1 files changed, 0 insertions, 33 deletions
diff --git a/gnu/packages/syndication.scm b/gnu/packages/syndication.scm
index 4d9811096b..f9a2a6a729 100644
--- a/gnu/packages/syndication.scm
+++ b/gnu/packages/syndication.scm
@@ -43,7 +43,6 @@
   #:use-module (gnu packages cmake)
   #:use-module (gnu packages crates-io)
   #:use-module (gnu packages curl)
-  #:use-module (gnu packages documentation)
   #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages glib)
@@ -336,38 +335,6 @@ file system, and many more features.")
     (license (list license:gpl2+        ; filter/*
                    license:expat))))    ; everything else
 
-(define-public newsboat-2.13
-  (package
-    (inherit newsboat)
-    (version "2.13")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (string-append "https://newsboat.org/releases/" version
-                           "/newsboat-" version ".tar.xz"))
-       (sha256
-        (base32
-         "0pik1d98ydzqi6055vdbkjg5krwifbk2hy2f5jp5p1wcy2s16dn7"))))
-    (build-system gnu-build-system)
-    (native-inputs
-     `(,@(fold alist-delete (package-native-inputs newsboat)
-               '("asciidoctor" "openssl"))
-       ;; For building documentation.
-       ("asciidoc" ,asciidoc)))
-    (inputs
-     (modify-inputs (package-inputs newsboat)
-       (replace "json-c" json-c-0.13)))
-    (arguments
-     '(#:phases
-       (modify-phases %standard-phases
-         (delete 'configure)            ; no configure script
-         (add-after 'build 'build-documentation
-           (lambda _
-             (invoke "make" "doc"))))
-       #:make-flags
-       (list (string-append "prefix=" (assoc-ref %outputs "out")))
-       #:test-target "test"))))
-
 (define-public liferea
   (package
     (name "liferea")