summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-26 14:53:40 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:21 +0200
commit51e2ec6f7f68812e6e223de717854cf132a6ede6 (patch)
tree37a04a5b1b15f042445772bd2efafbc5df02f64b /gnu/packages
parent8d0b56dd4bcd80ad1e0b20d3c24d7f568d97490b (diff)
downloadguix-51e2ec6f7f68812e6e223de717854cf132a6ede6.tar.gz
gnu: Add texlive-luahyphenrules.
* gnu/packages/tex.scm (texlive-luahyphenrules): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index cc0f3139dc..f84ef1fb2c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -16427,6 +16427,28 @@ integers as a linear combination.  The Bezout's Identity can be verified for
 any two integers using commands in the package.")
     (license license:lppl1.3c)))
 
+(define-public texlive-luahyphenrules
+  (package
+    (name "texlive-luahyphenrules")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/lualatex/luahyphenrules/"
+                   "tex/lualatex/luahyphenrules/")
+             (base32
+              "1a23bp4a7nix4lhi4dl6kwxp1bs6dvldxxrx143i1ps95l3clasj")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/luahyphenrules")
+    (synopsis "Loading patterns in LuaLaTeX with @file{language.dat}")
+    (description
+     "Preloading hyphenation patterns (or hyphen rules) into any format based
+upon LuaTeX is not required in LuaTeX and recent releases of Babel don't do it
+anyway.  This package is addressed to those who just want to select the
+languages and load their patterns by means of @file{language.dat} without
+loading @code{babel}.")
+    (license license:lppl1.3+)))
+
 (define-public texlive-babel-czech
   (package
     (name "texlive-babel-czech")