summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-07-02 15:22:16 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2019-11-15 17:32:25 +0100
commit534537e2efd7ff3d521a0c4cc60170a126d9c9f3 (patch)
tree2536882fd7ac19c8ed2a652a625f11a0cad14aea /gnu/packages
parentbdcdd55000c61f46649164fe43289f33c6132417 (diff)
downloadguix-534537e2efd7ff3d521a0c4cc60170a126d9c9f3.tar.gz
gnu: cmake: Fix cross-compilation.
* gnu/packages/cmake.scm (cmake-minimal-cross): New package.
* guix/build-system/cmake.scm (default-cmake): Add new target argument and use
it to select cmake-minimal or cmake-minimal-cross.
(lower): Pass target to default-cmake.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cmake.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index 64349be444..13252a9486 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -219,6 +219,14 @@ and workspaces that can be used in the compiler environment of your choice.")
                (append (search-patches "cmake-curl-certificates.patch")
                        (origin-patches (package-source cmake))))))))
 
+(define-public cmake-minimal-cross
+  (package
+    (inherit cmake-minimal)
+    (name "cmake-minimal-cross")
+    (native-search-paths '())
+    (search-paths
+     (package-native-search-paths cmake-minimal))))
+
 (define-public emacs-cmake-mode
   (package
     (inherit cmake)