summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNikita Karetnikov <nikita@karetnikov.org>2013-02-07 09:07:27 +0000
committerNikita Karetnikov <nikita@karetnikov.org>2013-02-09 12:05:01 +0000
commit54845460eeb749dc1d04d66469a3cb3bef11a785 (patch)
tree639ea13cb5f60ed1022e2b8576c01e65e00534e8 /gnu/packages
parenta38f0ab0b9e1d6959521dbf5852a4715205c3639 (diff)
downloadguix-54845460eeb749dc1d04d66469a3cb3bef11a785.tar.gz
gnu: Add GNU Smalltalk.
* gnu/packages/smalltalk.scm: New file.
* Makefile.am (MODULES): Add it.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/smalltalk.scm62
1 files changed, 62 insertions, 0 deletions
diff --git a/gnu/packages/smalltalk.scm b/gnu/packages/smalltalk.scm
new file mode 100644
index 0000000000..233068509d
--- /dev/null
+++ b/gnu/packages/smalltalk.scm
@@ -0,0 +1,62 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages smalltalk)
+  #:use-module (guix licenses)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix build-system gnu)
+  #:use-module (gnu packages zip))
+
+(define-public smalltalk
+  (package
+    (name "smalltalk")
+    (version "3.2.4")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append "mirror://gnu/smalltalk/smalltalk-"
+                          version ".tar.xz"))
+      (sha256
+       (base32
+        "1bdhbppjv1fswh4ls9q90zix38l1hg9qd4c4bz1pbg1af991xq3a"))))
+    (build-system gnu-build-system)
+    (inputs `(("zip" ,zip)))
+    (arguments
+     `(#:phases (alist-cons-before
+                 'configure 'fix-libc
+                 (lambda _
+                   (let ((libc (assoc-ref %build-inputs "libc")))
+                     (substitute* "libc.la.in"
+                       (("@LIBC_SO_NAME@") "libc.so")
+                       (("@LIBC_SO_DIR@")  (string-append libc "/lib")))))
+                %standard-phases)))
+    (home-page "https://www.gnu.org/software/smalltalk/")
+    (synopsis
+     "GNU Smalltalk, a free implementation of the Smalltalk-80 language")
+    (description
+     "GNU Smalltalk is a free implementation of the Smalltalk-80 language.
+
+In the Smalltalk language, everything is an object.  This includes numbers,
+executable procedures (methods), stack frames (called method contexts or block
+contexts), etc.  Each object is an \"instance\" of a \"class\".  A class can
+be thought of as a datatype and the set of functions that operate on that
+datatype.  An instance is a particular variable of that datatype.  When you
+want to perform an operation on an object, you send it a \"message\", and the
+object performs an operation that corresponds to that message.")
+    (license gpl2+)))