summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-19 11:28:50 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:44 +0200
commit55019ebccc8fe51a5a2e8733642f2c0458a58fb2 (patch)
treefab6b26d625f30dbe9f4f81e2dd1e75f4e451ff2 /gnu/packages
parent5b5f5a2f977da9af91f26fa08238f91f7dd89dc9 (diff)
downloadguix-55019ebccc8fe51a5a2e8733642f2c0458a58fb2.tar.gz
gnu: Add texlive-splines.
* gnu/packages/tex.scm (texlive-splines): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index d6595a3ad5..3729e79db8 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6273,6 +6273,26 @@ result in the same document.")
 without intervention from other utilities (except a distiller).")
     (license (license:fsf-free "file://metapost/slideshow/slideshow.mp"))))
 
+(define-public texlive-splines
+  (package
+    (name "texlive-splines")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/metapost/splines/" "metapost/splines/"
+                   "source/metapost/splines/")
+             (base32
+              "15pvr4vl5whcrij6gq3al5jaqrshvm2qybvxq7qx0gdxzfsli38z")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/splines")
+    (synopsis "MetaPost macros for drawing cubic spline interpolants")
+    (description
+     "This is a small package of macros for creating cubic spline interpolants
+in MetaPost or Metafont.  Given a list of points the macros can produce
+a closed or a relaxed spline joining them.")
+    (license license:lppl1.3+)))
+
 (define-public texlive-stackengine
   (package
     (name "texlive-stackengine")