summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-06 21:11:40 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-06 21:11:40 +0000
commit5729b2b3521aa9d4a88c8ac680bd37ffe3b3acc6 (patch)
tree4b8d8185bf87bc30a2e050b4ebdd9412b1eaed9d /gnu/packages
parent5dee582c135f4e3e639b8b2a9d502037053075d9 (diff)
downloadguix-5729b2b3521aa9d4a88c8ac680bd37ffe3b3acc6.tar.gz
gnu: python-traittypes: Simplify package.
* gnu/packages/python-science.scm (python-traittypes) [build-system]:
Swap to pyproject-build-system.
[arguments]: Move excluded tests to <#:test-flags>. Use standard 'check
phase.

Change-Id: I4cab0c94036a7e5f0851edf2833dfac2f675d2a0
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-science.scm13
1 files changed, 4 insertions, 9 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 30547e9cbe..2e0a17aac7 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -2153,16 +2153,11 @@ to do spectral analysis in Python.")
        (uri (pypi-uri "traittypes" version))
        (sha256
         (base32 "1mlv93irdrgxrhnhq3ksi9585d55bpi4mv9dha4p8gkkjiia4vxy"))))
-    (build-system python-build-system)
+    (build-system pyproject-build-system)
     (arguments
-     '(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
-             (when tests?
-               ;; This one test fails because it doesn't raise an expected
-               ;; exception.
-               (invoke "pytest" "-vv" "-k" "not test_bad_values")))))))
+     (list
+      ;; This one test fails because it doesn't raise an expected exception.
+      #:test-flags #~(list "-k" "not test_bad_values")))
     (propagated-inputs (list python-traitlets))
     (native-inputs
      (list python-numpy