summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-12-18 11:01:33 +0100
committerLudovic Courtès <ludo@gnu.org>2015-12-18 11:04:22 +0100
commit594e7b479a676dc74693b158522af93f5daa088f (patch)
tree75f8ef4d00d18fc463af0181c59b798ce3fe03d5 /gnu/packages
parentae115bc75a4a70f473608a60720c048d771f1885 (diff)
downloadguix-594e7b479a676dc74693b158522af93f5daa088f.tar.gz
gnu: python2-pygtk: Add "doc" output.
* gnu/packages/gtk.scm (python2-pygtk)[outputs]: New field.
[arguments]: Add 'set-gtk-doc-directory' phase.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gtk.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index ccd9ad57cf..279c06294e 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -994,6 +994,8 @@ extensive documentation, including API reference and a tutorial.")
        (base32
         "04k942gn8vl95kwf0qskkv6npclfm31d78ljkrkgyqxxcni1w76d"))))
     (build-system gnu-build-system)
+    (outputs '("out"
+               "doc"))                            ;13 MiB of gtk-doc HTML
     (native-inputs
      `(("pkg-config" ,pkg-config)))
     (inputs
@@ -1006,6 +1008,13 @@ extensive documentation, including API reference and a tutorial.")
     (arguments
      `(#:tests? #f
        #:phases (modify-phases %standard-phases
+                  (add-before 'configure 'set-gtk-doc-directory
+                    (lambda* (#:key outputs #:allow-other-keys)
+                      ;; Install documentation to "doc".
+                      (let ((doc (assoc-ref outputs "doc")))
+                        (substitute* "docs/Makefile.in"
+                          (("TARGET_DIR = \\$\\(datadir\\)")
+                           (string-append "TARGET_DIR = " doc))))))
                   (add-after 'configure 'fix-codegen
                     (lambda* (#:key inputs #:allow-other-keys)
                       (substitute* "pygtk-codegen-2.0"