summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-12-02 05:46:07 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2017-12-05 16:37:48 +0100
commit59e08129666ab3fde11473ed71cfaf8f1539aac7 (patch)
tree97dfd5711af017122bf7d30a11324e10f3937265 /gnu/packages
parent6d39aee5216b8bac8bf3059a62f84ed3dc3f1032 (diff)
downloadguix-59e08129666ab3fde11473ed71cfaf8f1539aac7.tar.gz
gnu: ghc-deepseq-generics: Update to 0.2.0.0.
* gnu/packages/haskell.scm (ghc-deepseq-generics): Update to 0.2.0.0.
[arguments]: Delete ‘relax-ghc-prim-dependency’ phase.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/haskell.scm12
1 files changed, 2 insertions, 10 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index de81e40dcc..1024370fe8 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -4375,7 +4375,7 @@ using a simple box model.")
 (define-public ghc-deepseq-generics
   (package
     (name "ghc-deepseq-generics")
-    (version "0.1.1.2")
+    (version "0.2.0.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://hackage.haskell.org/package/"
@@ -4383,16 +4383,8 @@ using a simple box model.")
                                   version ".tar.gz"))
               (sha256
                (base32
-                "01pvigx8n9p8hwbzp2qiq6kzf7cxiam843jz2sjgliacmmp1v7l3"))))
+                "17bwghc15mc9pchfd1w46jh2p3wzc86aj6a537wqwxn08rayzcxh"))))
     (build-system haskell-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'relax-ghc-prim-dependency
-          (lambda _
-            (substitute* "deepseq-generics.cabal"
-              (("< 0.4") "< 0.5"))
-            #t)))))
     (native-inputs
      `(("ghc-hunit" ,ghc-hunit)
        ("ghc-test-framework" ,ghc-test-framework)