summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-05-22 17:02:23 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-08-14 19:37:55 +0300
commit5b5dc462dd25f71a5d6ac0cff4e5ef5dc29e82a4 (patch)
treef9d5b4b7e50d9361eb809a5c93df9920f53bb80a /gnu/packages
parent067cfeeeb4d5106699e8117695dd63dc5960e42e (diff)
downloadguix-5b5dc462dd25f71a5d6ac0cff4e5ef5dc29e82a4.tar.gz
gnu: Add rust-object-0.30.
* gnu/packages/crates-io.scm (rust-object-0.30): New variable.
(rust-object-0.29): Inherit from rust-object-0.30.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm38
1 files changed, 33 insertions, 5 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 0dc66ae1ba..5f0c1bdae3 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -41170,25 +41170,28 @@ representation and parsing.")
     (description "This package provides procedural macros for the objc2 project.")
     (license license:expat)))
 
-(define-public rust-object-0.29
+(define-public rust-object-0.30
   (package
     (name "rust-object")
-    (version "0.29.0")
+    (version "0.30.3")
     (source (origin
               (method url-fetch)
               (uri (crate-uri "object" version))
               (file-name (string-append name "-" version ".tar.gz"))
               (sha256
                (base32
-                "0lzblxwxcih7j4z2cfx9094caax97hlfm9n0y5hlavda6cn8n591"))))
+                "0fdl7qjsz1j9kl3j7f4656fswzrqpyj2kgaizhknmjrx7mfjd1pa"))))
     (build-system cargo-build-system)
     (arguments
-     `(#:skip-build? #t
+     `(#:cargo-test-flags
+       '("--release" "--"
+         ;; Not all files are included
+         "--skip=read::coff::coff_extended_relocations")
        #:cargo-inputs
        (("rust-compiler-builtins" ,rust-compiler-builtins-0.1)
         ("rust-crc32fast" ,rust-crc32fast-1)
         ("rust-flate2" ,rust-flate2-1)
-        ("rust-hashbrown" ,rust-hashbrown-0.12)
+        ("rust-hashbrown" ,rust-hashbrown-0.13)
         ("rust-indexmap" ,rust-indexmap-1)
         ("rust-memchr" ,rust-memchr-2)
         ("rust-rustc-std-workspace-alloc" ,rust-rustc-std-workspace-alloc-1)
@@ -41201,6 +41204,31 @@ representation and parsing.")
 file formats.")
     (license (list license:asl2.0 license:expat))))
 
+(define-public rust-object-0.29
+  (package
+    (inherit rust-object-0.30)
+    (name "rust-object")
+    (version "0.29.0")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "object" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0lzblxwxcih7j4z2cfx9094caax97hlfm9n0y5hlavda6cn8n591"))))
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-compiler-builtins" ,rust-compiler-builtins-0.1)
+        ("rust-crc32fast" ,rust-crc32fast-1)
+        ("rust-flate2" ,rust-flate2-1)
+        ("rust-hashbrown" ,rust-hashbrown-0.12)
+        ("rust-indexmap" ,rust-indexmap-1)
+        ("rust-memchr" ,rust-memchr-2)
+        ("rust-rustc-std-workspace-alloc" ,rust-rustc-std-workspace-alloc-1)
+        ("rust-rustc-std-workspace-core" ,rust-rustc-std-workspace-core-1)
+        ("rust-wasmparser" ,rust-wasmparser-0.57))))))
+
 (define-public rust-object-0.28
   (package
     (inherit rust-object-0.29)